Prerequisites

This section of the docs will detail the software you will need to install in order to run and compile this demo.

Node.js Install

You can download the latest of node.js from here alternatively there are guides on how to install using a package manager.

Once you have installed node you can check that it is working correctly by opening a command prompt / terminal and typing

node --version

and see something like this

$ node --version
v8.7.0

Note - Both the Angular CLI and generated project have dependencies that require Node 6.9.0 or higher, together with NPM 3 or higher.

Git

You will also need to install the Git source control system on your machine. Check out this guide on how to install on Windows, Mac and Linux.

Npm

You will need the node package manager installed in order to fetch the packages that the demo needs. This should have been installed in the Node.js step above.

To check if npm is installed run the following.

npm --version

you should see something like this

$ npm --version
5.4.2

Angular CLI

Once you have node set up, installing angular cli is easy. Just run this command:

npm install -g @angular/cli

results matching ""

    No results matching ""